COGENT Online
CONTENTS
COGENT Help

The Project Manager

The Project Manager is a Windows tool allowing Cogent models and associated files to be grouped into a directed graph showing the development over a time of a Cogent Research project. The Project Manager presents to the user a tabbed dialog (shown below) containing two tabs, a History tab in which the project is represented as a directed graph in which each node corresponds to a Cogent model or to some associated file, and a Description tab containing a textual description of the project.

Figure 1: The Project Manager's User Interface.

How to ...

Select the current element

When the Project Manager's History tab is open a current element may be selected. The current element is either a node or an arrow between two nodes and is selected by clicking on that link or node. Various operations, as described below, make use of the current element.

Delete the current element

The current element may be deleted from the project by selecting the Edit->Cut menu item or its associated toolbar button. Note that deleting a node from a project does not delete the file that the node represents, it simply removes the link between the project and that file.

Add an existing file to a project

Any file may be added to the project by selecting that file in the Windows Explorer, dragging it, and then dropping it into the Project Manager's History Tab.

Create a new version of the current node

A new version of the current node can be created using the Edit->New Version of Current Node menu item or its associated toolbar button. A new node is created in the project which is connected by an arrow to the current node and which corresponds to a copy of the file represented by that node.

Create a new cogent model

A new, initially empty, cogent model may be created and added to the project by selecting the Edit->New Model menu item or its associated toolbar button then clicking at the position in the History tab at which the node representing the new model should appear.

Create an arrow between two nodes

To create an arrow between two nodes select the Edit->New Link menu item or its associated toolbar button then click on the node at which the arrow is to originate, then, holding the mouse button down, drag to the node at which the arrow is to terminate.

Cut, copy, and paste elements

Once the current element has been deleted using the Edit->Cut menu item as described above, it may be pasted back using the Edit->Paste menu item or its associated toolbar button. Elements may also be copied and pasted if the Edit->Copy menu item or its toolbar button is used in place of Edit->Cut.

However it is important to note that copying a node in his way does not create a copy of the file represented by that node, it simply creates a second link between the project and that file.

Import a Unix Cogent project

Unix COGENT stores projects as a hierarchy of files as indcated in figure 2 below.

Figure 2: The Medical Diagnosis Project Stored in Unix Format.

The project's top level folder, which in figure 2 is the folder MedicalDiagnosis, contains a file called history along with various folders with nine figure names which contain the project's models. The project may be imported as follows:

The project and the models it contains will then be converted. Warning The format of Unix Cogent projects and models has changed over the years, Windows Cogent attempts to recognise old Unix formats where possible but it is advisable to use the Unix Project manager to convert your project to the latest Unix Cogent format before converting it to Windows format.

How the Project Manager stores and locates files

A project is stored as a file with the extension ".prj". This file refers to, but does not contain, the files that are represented by the project's nodes. In general the files representing the nodes should be placed in the same folder as the ".prj" file representing the project. If this is done then it is possible to move the project, along with the files representing the nodes, from one folder to another, or from one disk to another, without the project losing track of which node represents which file. When a new cogent model is created using the pproject manager's Edit->New Model menu item, or its associated toolbar button, the newly created model will be placed in the same directory as the ".prj" file provided that the project has previously been saved. It is advisable to save a project before creating any new models within that project.

The Project Manager Toolbar

Each button on the rule editor toolbar corresponds to a menu item, as follows:

ButtonAction PerformedEquivalent Menu Item
Create a new project File->New
Open an existing project File->Open
Save the current project File->Save
Delete the current element Edit->Cut
Copy the current element into an internal buffer, ready for pasting Edit->Copy
Paste back a deleted or copied element Edit->Paste
Print the currently selected tab File->Print
Display version info. Help->About Project Manager
Display context sensitive help (not implemented) None
Insert new arrow Edit->New Link
Create new model Edit->New Model
Create new version of current node Edit->New Version

COGENT Online
CONTENTS
COGENT Help