COGENT Online
CONTENTS
COGENT Help

Printing

COGENT provides facilities for printing complete projects, complete models, or any of a model's component boxes. A complete project can be printed by clicking on the Print button on the model's history window. A complete model can be printed by selecting Print from the File menu on the model's top-level window (i.e., its principal box/arrow editor window). Details of specific boxes can be printed in an analogous way, by selecting Print from the File menu on the main window associated with the box in question. The details of individual boxes can also be printed by selecting Print from the menu that appears when you right click over the desired box on a box/arrow editor. A variety of other parts of a model may also be printed (e.g., the output trace). Print buttons occur in a variety of contexts within COGENT, and all printouts are governed by the details given below.

Selecting Print opens a new dialogue box, which presents a number of options, and at the bottom of the box, two buttons which allow the user to either cancel the operation or go ahead with the printing. The printing dialog window is shown in figure 1:



Figure 1: The Printing Dialog Window

The Print facility can be used to generate plain ASCII text files, nicely formatted PostScript files, or moderately well formatted HTML files. Which of these options is chosen, and the layout of the resultant printout is determined by the values specified in the print dialogue box. The dialogue items, their values, and the resulting behaviour, are as follows:

The default options in the printing dialog can be set using the Print Options menu, which has a similar layout to the main print dialogue shown above.


COGENT Online
CONTENTS
COGENT Help